I have noticed a lot of traffic coming to my site looking for my old Joomla components, if you landed on this page you were probably browsing a site that still has links to me.

I no longer create Joomla components and cannot support the ones I have created. Most did not work in Joomla 1.5 and I have since moved to a more simple setup.

Because I cannot support them, I cannot offer them for download. You should never run components or modules that have no updates or support to fix bugs and holes.